Script Backup Mikrotik Kirim ke e-mail

mikrotik logo customNambah share lagi di sini saya akan share tentang sebuah script yang kemarin baru saya buat untuk sebuah perusahaan besar di daerah bekasi agar backupnya dikirim via email langsung saja ke tutorailnya ya.

Kita harus setting dulu tools -> email , ini digunakan untuk mengirim email melalui port smtp jadi kita harus punya akun email dulu agar bisa di gunakan oleh mikrotik untuk mengirim email. screenshootnya dibawah ini .emailSelanjutnyanya masukan scripts dibawah ini ke dalama system -> scripts

:log info "Backup konfigurasi Mikrotik dimulai . . ."
:global backupfile configbackup
:global mikrotikexport exportbackup
:log info "Menghapus file backup lama jika ada,.Jika tidak, abaikan. Lanjutkan proses berikutnya . . ."
/system backup save name=backupfile
/export file=mikrotikexport
:log info "Mulai proses backup . . ."
:delay 10s
:log info "Mulai mengirim file backup lewat email . . ."
/tool e-mail send to=log.rexsolusi@gmail.com subject=("Mikrotik Config Backup_".[/system clock get date]) body=("Berikut ini file backup tanggal :" .[/system clock get date] ." supported by Rex Solusi Indonesia") file=backupfile tls=yes
/tool e-mail send to=log.rexsolusi@gmail.com subject=("Mikrotik Config Backup_".[/system clock get date]) body=("Berikut ini file backup tanggal :" .[/system clock get date] ." supported by Rex Solusi Indonesia") file=mikrotikexport tls=yes
:delay 40s
:log info "Proses Backup dan pengiriman lewat email Selesai."
:log info "Menghapus Backup File. Semuanya Selesai."
/file remove backupfile
/file remove mikrotikexport

setelah itu jalankan script tersebut bisa langsung dijalankan, bisa menggunakan scheduler , sekian terima kasih semoga bermanfaat

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s